AutoCAD 安装出现 NET4.5 问题的解决方法

安装 AutoCAD 2016 时弹出 Net Framework 4.5 没有安装的错误导致软件不能安装,查看 win10 自带的 Net 版本号是 4.6,默认向下兼容,于是判定问题原因是 AutoCAD 版本无法识别 Net4.6 所致,解决办法修改注册表中 Net 版本号,安装后还原即可。

出现 NET4.5 问题解决流程

1、进入控制面板——程序——启用或关闭 Windows 功能,把对应 NET 版本的对钩钩上。

2、打开注册表编辑器(运行——regedit),找到 “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Client” 右键——权限——高级,在弹出窗口中可以看到所有者是 trustedinstaller。修改所有者为 administrators,勾选 “替换子容器和对象的所有者”,确定,回到文件夹权限中,选中 Admininstrators,勾选允许完全控制,确定。

PS:所有者待以后系统更新会自动还原,请不要担心。

3、修改右侧 Version 值,先记录下来方便最后恢复,然后将数值改为 4.5.50938,就可以正常安装软件了。

4、最后重新修改 Version 值,将其改回原值即可。

点赞